Unable to access to the aplication



  • Is a bug in the application. I used fiddler for see what is happening in the call, and the application is sending nothing.
    I have the ports unlocked, because if not i cant use the https protocol, and my country dont block anything.

    I think that is something about the language of the computer, that is making a error in the application. You are losing money because that.

    Regards.



  • @gabi92a, that's a good idea. It could be the Spanish language on the computer. If so I'm sure I can solve that because I should be able to reproduce it by switching my computer to Spanish. Thanks for that idea.

    EDIT: I tried it - I installed Spanish language on my Windows 10 box and set my region to Spain. Unfortunately it still works for me.
    Are you using Windows 10?

    BTW, I appreciate you not giving up. I really want to solve this. Like you said, I'm loosing money.



  • @gabi92a, would you be willing to try this? This will run the agent without the GUI. I suspect the bug is in the GUI.

    1. Install NodeJS
    2. Open a cmd prompt
    3. Run this: node %userprofile%\AppData\Local\TRIGGERcmdAgent\app-1.0.21\resources\app\src\agent.js --console


  • @russ Token login failed using the console :(



  • @gabi92a, thank you for testing. That narrows it down. I created a branch with updated dependencies for you to test (if you're willing). I'm hoping this solves the problem.

    • Create a folder on your C: drive
    • Open a cmd window, and cd to that folder.
    • Install git if you don't already have it.
    • Run this:
      git clone -b spain https://github.com/rvmey/TRIGGERcmd-Agent.git
    • cd into the TRIGGERcmd-Agent subfolder.
    • Run this:
      npm install
    • Run this:
      node src\agent.js --console
    • Paste in your token

    If that works, then I believe I can produce a new version that will work on spanish Windows computers.



  • @russ said in Unable to access to the aplication:

    node src\agent.js --console

    Weird error installing: https://gyazo.com/e769546f7621fda85951352a2223a47b

    Result failed inserting the token: https://gyazo.com/8dfc9f27f419c3a100a7078a7cb843eb

    Regards.



  • Thanks @gabi92a, that's helpful, but I should have added some debugging output.

    I added these lines:

      console.log("Response from server:");
      console.log(response);
      console.log("Error from request:");
      console.log(error);
    

    Please try this updated code with these steps:

    • Open a cmd window, and cd to that c:\TRIGGERcmd\TRIGGERcmd-Agent folder.
    • Run this:
      git pull
    • Run this:
      node src\agent.js --console
    • Paste in your token

    Also, it looks like you ran node install.js instead of npm install. What does that do?



  • @russ said in Unable to access to the aplication:

    node src\agent.js --console

    Result: https://gyazo.com/afe127ffd8783f80a4f1e11b09bb4da5

    No, i ran the npm install.

    Regards.



  • Is an error 400, but im not seeing nothing in fiddler, there is no call???? :(



  • @gabi92a, I found out why Fiddler wasn't working. For NodeJS apps like the TRIGGERcmd agent, you have to set these environment variables before you run the node src\agent.js --console command:

    set https_proxy=http://127.0.0.1:8888
    set http_proxy=http://127.0.0.1:8888
    set NODE_TLS_REJECT_UNAUTHORIZED=0
    

    That tells the NodeJS app to use Fiddler as a proxy server.
    I found that here: https://weblogs.asp.net/dixin/use-fiddler-with-node-js

    Can you try that? Maybe that will give us a clue.

    Also, you could try running it after setting this variable to get a bunch of debug output:

    set NODE_DEBUG=*
    

    One thing you should know - the agent uses a websocket to connect to the server, and that connection doesn't use the https_proxy variable so Fiddler won't pick that up. The request that's giving us this error doesn't use websockets though, so that shouldn't matter for this troubleshooting.


Log in to reply