java jason error on attempt to install windows agen

  • I am trying to install the window agent for triggercmd and i get a java error.
    i found a similar post in the forums with the advise to delete the command.json and command.json.backup files... i deleted the command.json but did not have a command.json.backup file. I also tried uninstalling the triggercmd application from the windows control panel and reinstalling the agent.... all those attempts led to the same error message on attempted reinstall

  • and just to confirm this is an amd a10 running windows 10 64 bit
    please help!

  • one more update... i tried deleting the entire triggercmd folder under c:\users (which was still there after i uninstalled the agent from the windows control panel). i also deleted the pc from my profile at
    this allowed me to run the agent exe app again and enter a fresh token but that ultimately led to the same java error saying that the command.json.backup file does not exist... and sure enough when i check the triggercmd file which was recreated there is a command.json file but no backupfile.
    i have a jpg of the exact error message but not sure how to post it in this forum.
    pls help. i am very excited to use this system.


  • @karl-g, please uninstall and re-download from the site. I took the new version I created last weekend down, and put v1.0.19 back because you and one other person reported this issue.

    EDIT: I found the problem and fixed it in the latest version of the agent, so now you won't get that error during the Windows agent installation.

  • Hi Russ,
    So following your instructions I was able to install the agent successfully but when I try to run a command using the "play" button in the GUI editor nothing happens. I am able to manually execute the batch file from explorer so I know that it works. it just seems that the agent is failing to actually run the file. its a very simple path too so I dont think the path is the issue:

    C:\x10 shorts\bedroom heater on.bat

    any thoughts?
    Thanks again for your help

  • @karl-g, I see you have a space in the path to your batch file, so you'll need to add quotes around it like this:

    "C:\x10 shorts\bedroom heater on.bat"

Log in to reply