Can't add triggercmd to Google Home

  • I have my triggers working. Now I want to connect it to my Google Home speakers. The docs say run discover from the Home App, but there is no discover. Add new just gives you a long list of potential devices, none of which are triggercmd.

    The doc also has a web link that gets me as far as a page with an allow or decline. Allow just goes to an empty google web page.

    Can triggercmd still work with Google Home? Most of these postings are quite old.

  • @km, I just unlinked and linked my account, then tested it, so from my perspective it's still working.

    I'm glad you told me the Discover tab is gone. I'll update the document right after I send this..

    Instead of the Discover tab, now you can:

    1. Open the Google Home app
    2. Tap the blue circle with the icon that looks like a drawer to get to the "Explore" tab, or get to it by tapping the three horizontal lines in the upper left, then tap Explore.
    3. Use the search field to search for triggercmd.
    4. Scroll down and find the Link option and tap it.
    5. Login and Accept.
    6. Tap the Google Assistant icon at the bottom and say, "ask TRIGGERcmd to run Calculator".

    I also verified this link worked to link my Google Account to my TRIGGERcmd account from my PC. Also btw, it's normal for that link to drop you off at the google page after linking.

  • Thanks Russell

    My new issue is getting a shortcut (routine) on Google Home for Trigger C M D commands. They work if I say them. For example if I say

    OK Google Tell TRIGGER C M D to run all lights off

    it works. But If I put

    Tell TRIGGER C M D to run all lights off

    as the action of a routine, I get

    "I don't know how to help with that yet."

    Any suggestions?

  • @km, i just tested using the "I'm home" routine. I had it do "ask trigger cmd to run calculator" and that worked. So please try something simple like that.

  • What I was missing was that in a shortcut I need "cmd" not "c m d".


  • @km, nice, that's good to know.

  • I'm trying to understand what I'm doing wrong... Everything was working great for about a year... Then I had my phone replaced. Now the Google home routines on my phone no longer triggers triggercmd...

    I see all my old triggers, but when you say them out loud, nothing happens

    When you tap on them, also nothing happens.... But when I download the triggercmd app on my phone it works

    But Google Home device still works (without my phone)

    Any suggestions?

  • @atmosphere, sorry I missed your post until just now. Can you confirm your phone is logged into the Home app as the same google user your Google Home uses? Also, can you try again today? If you were using the Trigger Command action (instead of the Trigger CMD action), that might explain it because there was a problem with the Trigger Command action until today.

  • How do I add the Triggercmd service in Google Home app? I've been seeking, but I can't find nothing :(...

  • @decio-accietto, when I tap the compass in the lower right, it brings up an "Explore" page with a search field. When I type Triggercmd in that field, I see two options: TRIGGERcmd and TRIGGER command. You can pick the one you like better. Some people prefer to say Trigger Command instead of Trigger C M D.

    Do you not see those when you search?

Log in to reply