I subscribed but still can't add more machines / commands



  • I got the email confirming subscription but no change in the user experience on triggercmd. could you have a look for me please? thanks.



  • @Wholepunch, I see that your account with the email that matches your forum account is subscribed.

    I see a computer called sdr.kat.house in that account with one command called "Gnome Editor".

    The reason I mention that is sometimes people create more than one account, and they subscribe one but then try to use the other.

    What happens if you try to run that command multiple times in a row from the Trigger button on the website? It should work.

    Also, can you check the Instructions page and tell me if it says, "You're already subscribed. Thank you for your support!" in red text about half way down?



  • @Russ Hi Russ - thanks for getting back to me. Yes sdr.kat.house is mine - my account is ade.taylor@live.co.uk, although the PP account I used is different, sorry, I should have mentioned that. I can confirm that I can run the gnome editor trigger multiple times, and the instructions page confirms me as susbscribed. I may be me doing something wrong - I have all the default commands enabled in the commands.json file, yet gnome editor is the only one which is available from the drop-down on triggercmd relating to sdr.kat.house. Appreciate the help. Ade.



  • This https://www.triggercmd.com/forum/topic/54/subscription-mail was the solution - problem was lack of background tasks showing up so I followed the process @Russ described and it's working now. Thanks!



  • @Wholepunch, good, I'm glad you got it working.



  • @Russ I now seem to have a permissions problem - I am more than happy to trawl the forums to see if I can fix it, and I don't want to monopolise your time, but while I have your attention and if it's a quick fix :-) ... I am using a trigger "open gate" to (you guessed it) send a command to a pi zero which replays my captured 433Mhz RF signal and.. opens the gate. The command is in the form of a shell script and it works fine if executed locally. I seem to have bumped into a permissions issue however - the actual command embedded in the sh script is "sendiq" (part of the rpitx project) and it requires sudo to run. I have tried prefixing the sendiq comand in the sh script with sudo, and also using sudo in my commands.json file, neither of which seem to work. Output from tailing syslog shows the command is issued to the pi when I ask Alexa to trigger it, but the gate remains firmly closed. I have experimented locally and I'm pretty sure that it's to do with permissions, as if I run the sh locally with no SUDO it seems to work but the gate doesn't open, whereas with SUDO in the sh script, bingo. Long-winded, sorry! Any ideas?



  • @Russ I was being a dick :-) needed to add full path to the binary. All working now. I'll write it up including the RF stuff for the forum. Thanks very much - really helpful product mate!



  • @Wholepunch, thank you! I still haven't tried a 433mhz project and I want to.



  • @Russ I'll get it together over the weekend, but essentially the RPITX project provided most of the answers for me https://github.com/F5OEO/rpitx it's a bit of a cludge as it uses a short wire on a Pi GPIO pin to TX, but it works just fine. I've also got a HackRF One, which was really useful for capturing and decoding the signal from the gate remote, but with a cheap RTL-SDR dongle you can do that with RPITX as well. I've even seen people getting stuff like rolljamming working with the Pi - which has been in the news in the UK as the basis of replay attacks used by car thieves. Radio was a whole new world to me and I have to say that after a few intense weeks of getting various projects built, I still feel like I know next to nothing :-). Main thing I learned - the right type of antenna for the application is crucial. Anyway, I'll waffle on about it in the forum but please don't hesitate to get in touch if I can help.

    Ade


Log in to reply