Subscription mail

  • Hi!

    First of all thanks for this beautiful service. I want to make a subscription but my mail address is the same of paypal, there is a way to change mail address of this account or something different to proceed with the subscription?

    Thanks again

  • @davboc , your email address for TRIGGERcmd does not have to match your Paypal address. It can match, but it does not have to match - either way works.

    Also if you want to change your TRIGGERcmd account's email address, you could just create a new account. To re-register your agent with your new account, just delete your token.tkn file, then Quit and re-open the TRIGGERcmd agent.

    The token.tkn file is in C:\Users(your user).TRIGGERcmdData on Windows, or ~/.TRIGGERcmdData on Linux and Mac.

    I'm glad you like the service! Tell your friends! :thumbsup_tone3:

  • @Russ sorry for my misunderstanding, now all it's clear.

    I payed the subscription fee but my account is still a free account... What can I do?

  • @davboc , please check again - I manually changed your account to subscribed. I see there was an error reading your email address. You might have found a bug. If so, thank you - I'll fix it right away.

    EDIT: You did find a bug (oops). I fixed it.

  • @Russ great work, I have a premium account now!

    Last question, I'm trying to install triggercmd on a raspberry pi following your guide, works fine but I can't add a command (or modify one of the list), every change at the commands.json file disappears when I reopen the file. I tried to stop the triggercmdagent then modify the commands.json, but when I start the triggercmdagent all changes are lost.

  • @davboc , I think I might know what's wrong. If you have a comma at the end of your commands.json file, it will revert it to the previous commands.json. In otherwords, it detects the problem and restores the backup.

    I've made that mistake a few times myself - if you copy a line and forget to remove that last comma, it's bad json format. You could past your json into this tool to check it:

    Here's my commands.json file from my Raspberry Pi. Notice the last line doesn't have a comma at the end.

    {"trigger":"Reboot","command":"shutdown -r","ground":"background","voice":"reboot"},
    {"trigger":"Russ Garage Door","command":"/root/","ground":"background","voice":"russ"},
    {"trigger":"Betsy Garage Door","command":"/root/","ground":"background","voice":"betsy"},
    {"trigger":"apt update","command":"apt-get -y update","ground":"background","voice":"update"},
    {"trigger":"boot russfam","command":"wakeonlan c0:7c:d1:a1:89:f8","ground":"background","voice":"boot"}

  • @Russ yes you're absolutely right, comma was the problem. However now I can modify the file, but I still can't see created triggers on the website and I can't execute the trigger that I've added...

  • @davboc,

    Did you install the background service? On a Raspberry Pi you'd generally only use the background service.

    Also use "ground":"background" instead of "ground":"foreground".

    You can install the background service with this command:

    Also, here's a troubleshooting tip for Linux/Raspberry Pi. If you run this, you'll see the latest output from the agent running as a background service (aka daemon):

    systemctl status triggercmdagent -l

  • @Russ yes I installed the service as explained in your guide, I tried both foreground and background but I still can't see my triggers, and of the default triggers I can only see "gnome editor" that is the only in foreground...

    Thanks again for your patience

  • @davboc , I'm happy to help. Thank you for your patience. We'll get this.

    I wonder if your Raspberry Pi is connected to your old account, if you created a new one today?

    Or maybe the background service isn't running now. You could check that with this command:

    systemctl status triggercmdagent

    You could try getting a fresh start like this:

    • Delete your Raspberry Pi computer record from your account here.
    • Delete your ~/.TRIGGERcmdData/token.tkn file.
    • Run: triggercmdagent (runs agent in foreground)
    • Paste in your token from the Instructions page.
    • CTRL-C out of the foreground agent.
    • systemctl restart triggercmdagent
    • systemctl status triggercmdagent
    • Check to see if the background commands were added.

    Please IM me your computer name - that might help me troubleshoot.

  • @Russ after that fresh start all works well. Thank you so much, I really appreciate your work

  • You're welcome @davboc. Thanks again for finding that Paypal bug.

Log in to reply