Using on Debian Buster

  • Hello,

    I have the trigger default for open gedit, i have tested and i can run it from triggercmd app at iOS, but when i do a routine inside alexa app, the alexa cant identify the task for Gnome Editor. I just can add a skill TriggerCMD, but inside it when i add it, nothing is identified.

    Anybody can help me? I just wanna test for later i buy full version.
    Best Regards!

  • Just for make my case more detailed.

    I cant found my triggers on smart home things.

    The application at linux, dont open, i just can set my token, after that no any interaction is possible.

  • @kaligora, to find triggers under Smart Home - Devices in the Alexa app, or at, you need to enable the TRIGGERcmd Smart Home Alexa skill, (not the original skill).

    Also your commands need to have something in the Voice field.


    In the default Linux commands, you'll see the Voice word for the Gnome Editor is edit.

  • Thanks for the fast asnwer, but i cant see a list or anything that i can add the new triggers, cause always when i try triggercmdagent at command line the error is:

    root@matrix:/home/igora# triggercmdagent
    No protocol specified
    (triggercmdagent:12474): Gtk-WARNING **: 18:19:40.141: cannot open display: :0
    Created symlink /etc/systemd/system/ → /etc/systemd/system/triggercmdagent.service.
    ● triggercmdagent.service - TRIGGERcmd Agent
       Loaded: loaded (/etc/systemd/system/triggercmdagent.service; enabled; vendor preset: enabled)
       Active: active (running) since Wed 2020-10-21 17:38:19 -03; 162ms ago
     Main PID: 7135 (node)
        Tasks: 6 (limit: 4915)
       Memory: 4.4M
       CGroup: /system.slice/triggercmdagent.service
               └─7135 node /usr/lib/triggercmdagent/resources/app/src/daemon.js --run /root/.TRIGGERcmdData
    out 21 17:38:19 matrix systemd[1]: Started TRIGGERcmd Agent.

    The daemon is running fine, but i cant add new triggers in it, how i can add it in command line, is that possible?

    Best Regards!

  • @kaligora said in Using on Debian Buster:


    I see you're not running X-Windows, or you're ssh'ed into your Linux box, so you can't run triggercmdagent because that would try to run the X-Windows GUI agent app.

    I see you installed it to run as a background agent though. That's good. You can edit your commands in /root/.TRIGGERcmdData/commands.json. Make sure they have "ground": "background" because the agent running in systemd runs in background mode.

    You can run one of these commands to edit that file:

    sudo vi /root/.TRIGGERcmdData/commands.json
    sudo pico /root/.TRIGGERcmdData/commands.json
    sudo nano /root/.TRIGGERcmdData/commands.json

Log in to reply