Alexa Issue



  • In my trigger cmd account when I manual Trigger the action it works fine on my computer, but when I ask alexa she says ok but nothing happens. I have told alexa to discover. Not Sure?

    Thanks



  • @k8nr, I assume you're using the TRIGGERcmd Smart Home Alexa skill, because you said you told Alexa to discover, which is only necessary for that skill.

    When you go to https://alexa.amazon.com, do you see your commands under Smart Home -> Devices?

    If not, you probably don't have the TRIGGERcmd Smart Home skill enabled. You can do that under Smart Home -> Smart Home Skills -> Enable Skills, then search for TRIGGERcmd Smart Home.

    If you do see your commands under Smart Home -> Devices, then scroll to the bottum of that screen and select Forget All, then Discover.

    BTW, what are you saying to Alexa? Something like, "turn on calculator" ?



  • Thanks for checking into the issue. I’m at work now so I will check as soon as I get home. The trigger just runs a shell script on my linux FreePBX machine that does certain types of automation. I am using “TRIGGERcmd Smart Home”. I first installed on an EXSi machine running FreePBX for testing purposes. The same Trigger and Alexa functioning worked great. So I put in a fresh drive to create the final production machine (not running ESXi) and renamed the hostname. I went to your website and choose that machine as the default computer. Tested the trigger from the web page, works great. Alexa not so well (says ok, but does not complete). So works great from your site by touching trigger, not from amazon.

    Also went to amazon skills –
    jen system report
    TRIGGERcmd host.linuxize.com >> systat

    The vocal command I use is “Jen system report ON”

    Thanks for your help!



  • Smart Home -> Devices, then scroll to the bottom of that screen and select Forget All, then Discover.

    Works great now! Thanks for your help!


Log in to reply