Two Commands Aren't working



  • I have the following:

    [

    {"trigger":"Reboot in 10 seconds","command":"shutdown /r /t 10","ground":"background","voice":"reboot"},

    {"trigger":"Scala","command":"C:\Program Files (x86)\Scala\Player\InfoChannelPlayer5.exe","ground":"foreground","voice":"Scala"},

    {"trigger":"Fluid","command":"C:\BLI\apps\FluidSim-BSP\FlowToolsTest.exe","ground":"foreground","voice":"Fluid Sim"},

    {"trigger":"Escape","command":"wscript c:\scripts\key.vbs esc","ground":"foreground","voice":"Escape"}

    ]

    "Reboot in 10 seconds" doesn't appear in the list when viewing my Windows PC through the website.

    Also, my "Scala" command doesn't seem to launch the app. "Fluid" works perfectly, however. Are there any common reasons why a script or app won't launch?

    Thank you to anyone who can share some advice!


  • administrators

    @mvk , I bet the reason "Reboot in 10 seconds" isn't showing up is it's a background command, so it will only show up if you install the background service. Did you do that? If you did, can you open services.msc and confirm the TRIGGERcmdAgent service is running?

    About the Scala command, please try pasting C:\Program Files (x86)\Scala\Player\InfoChannelPlayer5.exe into the GUI editor. I think you probably added that command using the Text Command Editor so it doesn't have all of the escape backslashes. For instance, this is what my Dropbox command looks like in the commands.json file:

    "command": "\"C:\\Program Files (x86)\\Dropbox\\Client\\Dropbox.exe\" /home",
    

    If you use the GUI Command Editor, you don't have to worry about all of those escape \'s (backslashes).



  • Apologies, I just noticed the form here corrected my post. This is actually what it says:

     [
        {"trigger":"Reboot in 10 seconds","command":"shutdown /r /t 10","ground":"background","voice":"reboot"},
        {"trigger":"Scala","command":"C:\\Program Files (x86)\\Scala\\Player\\InfoChannelPlayer5.exe","ground":"foreground","voice":"Scala"},
        {"trigger":"Fluid","command":"C:\\BLI\\apps\\FluidSim-BSP\\FlowToolsTest.exe","ground":"foreground","voice":"Fluid Sim"},
        {"trigger":"Escape","command":"wscript c:\\scripts\\key.vbs esc","ground":"foreground","voice":"Escape"}
     ]
    

    I can try it with the /home. I've been editing the file with Notepad based on your documentation, and escaped the 's using your freeformatter.com link. I'll repost after I play around a bit more.

    I'll also ensure the background service is running.

    Thanks!


  • administrators

    @mvk /home was just for my Dropbox command.

    Can you send me a link to my doc that says to use Notepad? I need to update that.

    If your agent is pulling up Notepad as your editor, you must not have the latest agent version.

    Also if your agent is that old, you'll want to uninstall the Background service before upgrading. The newest versions have an Upgrade agent option that does that for you, then downloads and installs the latest version.



  • I found a solution. Perhaps it's obvious to others, but I'm not super familiar with running command line on Windows.

    Instead of:

     C:\Program Files\Folder\Program.exe
    

    I used:

     start C:\"Program Files"\Folder\Program.exe
    

    Seemed to not like strings with spaces. Everything is peachy now.



  • Also, the server I'm using this on hid the task bar icons, so it was a little while before I realized there was a place to right-click and pull up a GUI editor =P. The directions on your website are not incorrect.


Log in to reply
 

Looks like your connection to TRIGGERcmd Forum was lost, please wait while we try to reconnect.