[Linux] Failed to start triggercmdagent.service



  • I can't get the background service to start. I installed it via the TriggerCMD tray icon, but I received no visual feedback other than the authentication prompt to run /bin/sh as su.

    ~ $ triggercmdagent
    Checking if the 598e58a42b4dea3166b86408 computer exists.
    This computer exists in your account.
    Tokenfile: /home/yochanan/.TRIGGERcmdData/token.tkn
    ComputerIDfile: /home/yochanan/.TRIGGERcmdData/computerid.cfg
    Logging in with saved token to run foreground tasks.
    ~ $ systemctl status triggercmdagent  
    ● triggercmdagent.service
       Loaded: not-found (Reason: No such file or directory)
       Active: inactive (dead)
    ~ $ systemctl start triggercmdagent
    Failed to start triggercmdagent.service: Unit triggercmdagent.service not found.
    

    I'm using TriggerCMD 1.0.1 on Linux Mint 18.2.

    Off topic, but I'm not able to login to the TriggerCMD Android app via Google+. I get a 403 page with Error: disallowed_useragent. Google no longer allows OAuth requests to be made via webview. Also, it seems like it's just a web wrapper anyway, I may as well just use the mobile site.


  • administrators

    @Yochanan , you're correct about the Android app - for now it's just a web wrapper with a cache. I'll work on updating the app to remove the Google login option for now. I recommend you go to https://www.triggercmd.com/user/computer/list and select "Add to Home screen". That's what I did. That way if you're already logged in, it goes right to your computer list.

    About your background service - I'll install Linux Mint on a VM to troubleshoot why that option in the tray icon isn't working. I've only tested on CentOS and Ubuntu so far.

    In the meantime, would you mind trying this?

    sudo /usr/share/triggercmdagent/app/src/installdaemon.sh
    

    EDIT: Correction, on Mint this is the path, and I noticed the file is not executable, so run:

    sudo sh /usr/share/triggercmdagent/resources/app/src/installdaemon.sh
    

    You don't want to switch to root first because you installed as your non-root user so you want it to look for your ~/.TRIGGERcmdData directory in your home directory.


  • administrators

    @Yochanan , I installed Linux Mint 18.2 with KDE as my window manager, and I was able to install the service via the tray icon. What window manager are you using?

    Mint Screenshot



  • Be sure to to autostart the service boot -
    sudo systemctl enable triggercmdagent.service


Log in to reply
 

Looks like your connection to TRIGGERcmd Forum was lost, please wait while we try to reconnect.