Turn on a computer



  • You may need to turn on Wake On Lan in your PC's BIOS first.

    I run this command on my Raspberry Pi to wake up my PC:

    wakeonlan c8:60:00:9b:69:1a
    

    Install the wakeonlan tool on a Raspberry Pi and some Linux distros like this:

    apt install wakeonlan
    

    There are multiple ways to get your PC's network card's mac address. One is to ping the PC, then type this to see all of the entries in your arp table:

    arp -a
    

    Also check out this post where I took this concept a little further and made a Youtube video.

    Pictures of Wake On Lan in your BIOS

    More info here

    Or here for some instructions sending the wakeonlan magic packet from a mac to a PC.



  • @Russ Does this command work by voice command at alexa?



  • @nuzibito, if it works from the website and it's on the printable voice command list, it should work fine with Alexa. If you're using the Smart Home skill, just remember to Discover devices at https://alexa.amazon.com.

    If you don't see it on the voice command lists, you probably need to fill in the voice field for the command and/or the computer.



  • @Russ I'm trying to connect a DELL R420 through IDRAC using IPMI, I created .sh to run through TRRIGERCMD I added the content to json but it doesn't appear in the cloud. the existing triggers are working normally ... just mine that add doesn't show.
    is running on raspberry py B + with Debian 10 buster.

    I bought an eco dot + I am waiting to arrive and use Alexa but I need to solve this could you help me please?

    is running on raspberry py B + with Debian 10 busterTriggerCMD2.png

    triggerCMD.png



  • @Wesley-Correa, I see some problems in your poweron trigger. The command path should start with a / (slash), ground should be background assuming you're running the background service, and the voice field should have a space because Alexa and Google probably won't match what you say to "poweron". It should be like this:

    {"trigger":"poweron","command":"/usr/bin/idrac.sh","ground":"background","voice":"power on","allowParams":"false"}
    

    If you run triggercmdagent from the command line like that, it runs the agent in foreground mode. If you want to test it that way, change ground to foreground, but in general I use the background service with a Raspberry Pi.



  • @Russ First thanks for feedback. see how this triggers however in the cloud appears only GNOMEtriggerIDRAC.png triggersCMD2.png



  • @Russ I changed the IDRAC trigger the ground parameter to foreground and it appeared in the cloud ... but why the IDRAC trigger does not appear when this background



  • @Wesley-Correa, the foreground agent adds/removes/runs foreground commands, and the background agent adds/removes/runs background commands. So I think the background agent isn't running.

    To install the background agent on the Pi, you'll need to do this:

    sudo su -
    /usr/share/triggercmdagent/app/src/installdaemon.sh
    

    Then you can check its status like this:

    systemctl status triggercmdagent
    


  • @Russ Okay, but how to identify the output from the command if this is first or second?plano.png



  • @Wesley-Correa, to capture the output of a command, you can make the command direct "standard out" and "standard error" to a text file like this:

    yourcommand &>> /tmp/commandlog.txt
    

    Use a single > if you want to over-write the txt file every time instead of appending to it.

    Please explain what you mean by "first or second".



  • @Russ I say that in the trigger parameter it is like {"trigger": "idrac", "command": "/ usr / bin / idrac.sh", "ground": "foreground", "voice": "power on", " allowParams ":" false "},

    foreground appears in the cloud, but when you put the background



  • @Wesley-Correa, when you switch your command from foreground to background, you can't tell which agent added it just by looking at the website. I suggest adding something to your trigger name to specify background, like this:

    {"trigger": "idrac background", "command": "/usr/bin/idrac.sh", "ground": "background", "voice": "power on", "allowParams":"false"},
    

    Then use systemctl status triggercmdagent to see that the background agent added it.

    BTW, I got rid of some extra spaces you had in your json entry that might have caused a problem.



  • @Russ Thank you all right now.



  • @Wesley-Correa, awesome. I'm glad that worked out.



  • Hello, I intend to create one more command, and share access. in that case I have to create another commands.json?

    because the entries created in commands.json I cannot share



  • @Wesley-Correa, if you share your computer with another TRIGGERcmd user, all of the commands on that computer are shared.

    Are you seeing the commands you created in commands.json on the website?


Log in to reply