Windows agent not updating triggers on triggercmd.com, ST smartapp?



  • I tried changing my command to a foreground command but that didn't show up either.

    I tried deleting the user data folder but I've done that again, restarted the agent, and put the token in. I left the default sample commands there (notepad and calculator foreground and the reboot pc command background command). I see the computer listed in the web interface with the two foreground commands, but the background command doesn't show up. Is that expected?

    If so, should I just use foreground commands?



  • @batteryxsnare, that is expected. You'll only get foreground commands until you install the background service. The background service installs and runs the background commands.

    So apparently deleting the .TRIGGERcmdData folder fixed it.



  • Well, now I've installed the background service and started it, but the sample reboot command which is a background command still listed in the web interface...is that expected?



  • @batteryxsnare, do you mean it's still not listed? If not, can you confirm the Triggercmd agent service is running?



  • Yes, the background command is still not listed, and the background service was running.

    I rebooted the PC and on reboot, the service didnt start on it's own but I manually started it and background command still isnt listed.



  • @batteryxsnare, ok, apparently there's something wrong with the background service if it's not staying started during boot. You could try "Remove Background Service" then "Install Background Service". If you have antivirus software, especially Avast, then I suggest temporarily disabling that while you do the remove/install. Sorry for all the trouble. If you tend to leave your computer logged in, you could just use foreground commands, but the background service should work. I use it on some of my Windows boxes, like my media center box because I don't keep myself logged in.



  • Only AV on the machine is Windows Defender...disabled real-time protection, uninstalled/re-installed background service but still not starting on reboot. Oh well, guess I'll just set the machine to auto-login and run foreground commands since they do seem to be working now.

    Thanks for your help



  • @batteryxsnare, sorry man. I don't get it. I hate giving up, but I understand if you're done. The debug.log file might have a clue if you want to send me that.



  • here it is:

    Checking if the 5c68c8523b309f00167a1439 computer exists.
    This computer exists in your account.
    Tokenfile: C:\Users\Jon Isaacson.TRIGGERcmdData\token.tkn
    ComputerIDfile: C:\Users\Jon Isaacson.TRIGGERcmdData\computerid.cfg
    Logging in with saved token to run foreground tasks.
    Write backup completed.

    |> Now connected to https://www.triggercmd.com.
    ___/ For help, see: http://bit.ly/2q0QDpf
    (using sails.io.js node SDK @v1.2.1)
    Connected at: Mon Feb 18 2019 07:13:20 GMT-0800 (Pacific Standard Time)

    Initiated command removals
    Initiated command adds
    { message: 'Subscribed to 5c68c8523b309f00167a1439!' }
    { message: 'Subscribed to 5c68c8523b309f00167a1439!' }

    |> Now connected to https://www.triggercmd.com.
    ___/ For help, see: http://bit.ly/2q0QDpf
    (using sails.io.js node SDK @v1.2.1)
    Connected at: Mon Feb 18 2019 07:16:41 GMT-0800 (Pacific Standard Time)

    { message: 'Subscribed to 5c68c8523b309f00167a1439!' }
    Opening GUI editor
    Downloading example commands
    Write backup completed.
    Initiated command adds
    Initiated command removals
    Write backup completed.
    Initiated command removals
    Initiated command adds
    Added TriggerCMD RifleSafe
    { trigger: 'TriggerCMD RifleSafe',
    id: '5c6acd71592b050016ee4fa1' }
    Running trigger: TriggerCMD RifleSafe Command: c:\ivbind\IvSendEvent -l 192.168.88.173 -n 100 10.69.1.111 -a Vibration
    Reported: Command Ran
    Write backup completed.
    Initiated command adds
    Initiated command removals
    Deleted Notepad
    Write backup completed.
    Initiated command adds
    Initiated command removals
    Deleted Calculator
    Write backup completed.
    Initiated command removals
    Initiated command adds
    Added TriggerCMD PistolSafe

    |> Now connected to https://www.triggercmd.com.
    ___/ For help, see: http://bit.ly/2q0QDpf
    (using sails.io.js node SDK @v1.2.1)
    Connected at: Mon Feb 18 2019 08:25:52 GMT-0800 (Pacific Standard Time)

    { message: 'Subscribed to 5c68c8523b309f00167a1439!' }

    |> Now connected to https://www.triggercmd.com.
    ___/ For help, see: http://bit.ly/2q0QDpf
    (using sails.io.js node SDK @v1.2.1)
    Connected at: Mon Feb 18 2019 10:10:06 GMT-0800 (Pacific Standard Time)

    { message: 'Subscribed to 5c68c8523b309f00167a1439!' }

    |> Now connected to https://www.triggercmd.com.
    ___/ For help, see: http://bit.ly/2q0QDpf
    (using sails.io.js node SDK @v1.2.1)
    Connected at: Mon Feb 18 2019 15:40:35 GMT-0800 (Pacific Standard Time)

    { message: 'Subscribed to 5c68c8523b309f00167a1439!' }

    |> Now connected to https://www.triggercmd.com.
    ___/ For help, see: http://bit.ly/2q0QDpf
    (using sails.io.js node SDK @v1.2.1)
    Connected at: Mon Feb 18 2019 16:01:19 GMT-0800 (Pacific Standard Time)

    { message: 'Subscribed to 5c68c8523b309f00167a1439!' }

    |> Now connected to https://www.triggercmd.com.
    ___/ For help, see: http://bit.ly/2q0QDpf
    (using sails.io.js node SDK @v1.2.1)
    Connected at: Mon Feb 18 2019 17:57:38 GMT-0800 (Pacific Standard Time)

    { message: 'Subscribed to 5c68c8523b309f00167a1439!' }

    |> Now connected to https://www.triggercmd.com.
    ___/ For help, see: http://bit.ly/2q0QDpf
    (using sails.io.js node SDK @v1.2.1)
    Connected at: Mon Feb 18 2019 21:19:16 GMT-0800 (Pacific Standard Time)

    { message: 'Subscribed to 5c68c8523b309f00167a1439!' }



  • @batteryxsnare, unfortunately I see no smoking gun in that output.


Log in to reply