TriggerCMD says that it can't find the computer



  • Hey guys,

    Yesterday I bought myself a Google Home Mini and decided to download TRIGGERcmd in order to use more commands.
    I installed it, configured the triggers and named my computer 'PC' (that is how my "Default Computer" is called as well). I set up the voice trigger for the computer to 'PC' as well.

    However, everytime I ask the Home Mini to do something, for example: "Hey Google, ask TRIGGERcmd to run chrome on PC", I get in response: "Okay, lets get TRIGGERcmd" and then a male voice that says: "I couldn't find a computer called PC".

    Does anyone know how to fix that? Thanks in advance!

    Also, I am struggling to find out how to do the commands properly.
    For example, if I add a command for Spotify, I set it (the command) as "start spotify" and then whenever I try to run it, I get a window telling me that "Windows cannot find 'spotify'. Make sure you typed the name correctly, and then try again."
    Setting up the command only to "spotify" does not do anything.

    Sorry, I am a newbie. :/


  • administrators

    Ashley, you only have one computer right? So you don't even have to say your computer name. If you only have one computer you can just say, "Hey Google, ask TRIGGERcmd to run chrome."

    That said, it should work, but you might want to try another voice trigger for your computer, like the word "computer". I just tried "pc" and "computer" though and they both worked for me. If that still doesn't work, let me know. I'd look at your account but I have to go - it's Christmas eve and time to go to my Dad's for dinner...

    Try this as your command to run Spotify. I tried it and it and it worked for me.

    %USERPROFILE%\AppData\Roaming\Spotify\Spotify.exe


  • Hey,

    Even if I say "Hey Google, ask TRIGGERcmd to run chrome", it won't execute.
    This time I am being told that "You haven't set a Default Computer on your TRIGGERcmd profile yet".. and I am damn sure I have!

    Regarding the second issue, that seems to work.

    Edit: Tried reinstalling the program, thinking this might solve the issue and now I can't reuse my token.. due to my stupidity I guess. ;-;

    Thank you and I wish you a Merry Christmas!


  • administrators

    @ashley12, I see you have 4 different TRIGGERcmd accounts. I think you might have associated the Google account you use for Google Assistant with a different TRIGGERcmd account from the one that was associated with the agent on your computer.

    To get the agent working again, you'll need to do these things:

    • Log into your TRIGGERcmd account - the one associate with Google Assistant.
    • Delete your computer
    • Delete or empty out your .TRIGGERcmdData folder. You'll see that folder if you type %userprofile% into Windows Explorer, or hold the Windows key and press R, then type %userprofile% and press enter.
    • Close the TRIGGERcmd agent, and re-open it.
    • Copy/paste the token in from the Instructions page.

    To figure out which Google account you use for Google Assistant, you can tap the little blue icon in the upper right in the Google Home app, then tap the three dots in the upper right, and tap Account.

    To make sure the correct TRIGGERcmd account is associated with that Google account, you can do the following:

    • Log in as that Google account in a web browser.
    • Go here in that browser: https://myaccount.google.com/permissions
    • Find TRIGGERcmd and click Remove Access.
    • Go here in that browser and click Allow, or you an just say "Talk to TRIGGERcmd" in the Google Home app and it should prompt you to re-link your account.

    EDIT: Correction - the "Trigger Cmd" entry at https://myaccount.google.com/permissions shows you the connection you made to your Google account if you log into the www.triggercmd.com website with your Google account. I haven't found a site that shows your Google Assistant login accounts yet.



  • Yeah, I might have too many accs xD in desperate tries to make it work...

    I did all of the steps you mentioned and I still get the same error..

    The funny thing is, on Alexa, the commands work..

    And yes, I've linked the TRIGGERcmd to my account...

    Edit: Nevermind, I tried after 30 minutes or so, and it worked!

    Now I have another (and last, I promise!) question.
    Can I set paths to executables that are not found under the AppData folder? I have a few programs that do not have their exe's under any of the AppData folders and simply setting their path to, let's say, C:\Program Files\so on\so on... won't trigger the command.


  • administrators

    @ashley12, that's awesome - I'm glad Google Assistant is working now.

    Feel free to ask more question. I'm happy to help.

    About paths to c:\Program Files\so on\so on... That should work, but you have to put quotes around any path that has spaces in it.

    I just tried Windows Media Player and this was the path:

    "C:\Program Files\Windows Media Player\wmplayer.exe"
    

    One way to easily get the full path with quotes is to find the .EXE file, right-click it, and click "Create shortcut". Then right-click the shortcut and click Properties. The Target field has the full path, so you can copy/paste that into the Command field in the TRIGGERcmd agent.



  • Thank you, everything works now!

    I tried to use the path with quotes yesterday, however it opened the command prompt instead but now it works, haha

    Thank you again for the help and for the nice application that you've created!



  • Hello Ashley,
    Try to make a shortcut for spotify then call that shortcut. It should work.



  • @gcabot
    Hey, I tried this out before @Russ told me how to fix the path, however that didn't work for some reason, but it's all fine now.

    Also, suddenly the system commands stopped working (for example, shutdown, hibernate, etc) and I wonder why since the commands are the standad ones (i.e., command: shutdown /s /t 10; ground: background). The background service is installed too..


  • administrators

    @asya, if your background commands aren't working you should try restarting your TRIGGERcmdAgent Windows service. You could try switching the shutdown command to a foreground command too.



  • @russ hi i was hoping you could help me out with this...i want to be able to shut down my computer i put the command as shutdown /s but when i ask google home the trigger command service says that it cant find a trigger named shutdown for my pc. could you possibly write out exactly what i would put in the GUI..like a basic trigger name and everything..? thanks i appreciate anything you may be able to give me on this information


  • administrators

    @buddahs808 ,

    The trick is to use a simple word for google to hear in the 'voice' field for the command.

    Does 'calculator' work?


Log in to reply
 

Looks like your connection to TRIGGERcmd Forum was lost, please wait while we try to reconnect.