TriggerCMD skill working, but not directly



  • @Nirav, I wonder if you disabled and re-enabled one skill, but you're actually trying to use a different skill. If you're trying to say, "Alexa, turn on/off calculator", the skill you're using is the "TRIGGERcmd Smart Home" skill.

    This page lists the skills: https://www.triggercmd.com/forum/topic/30/list-of-ways-to-trigger-your-commands

    There are actually three Alexa TRIGGERcmd skills:

    TRIGGERcmd original skill (Alexa, ask TRIGGERcmd to run calculator)
    TRIGGER command original skill (Alexa, ask TRIGGER command to run calculator)
    TRIGGERcmd Smart Home skill (Alexa, turn on calculator)

    If you're in the US and you're already logged into alexa.amazon.com, you could use this link to go directly to the TRIGGERcmd Smart Home skill:
    https://alexa.amazon.com/spa/index.html#skills/dp/B07P1MMFRP/?ref=skill_dsk_skb_sh_0&qid=b8976b50-65ef-40d1-bbf3-e7425c911101



  • This happened to me too, without changing anything. Running the script manually works, but asking Alexa to run does not work. Does this have anything to do with the recent windows update?



  • @rafaelramon, no it shouldn't have anything to do with the recent Windows update if you can run the command manually from the Trigger button on the website.

    I suspect Alexa isn't recognizing your voice word. What are you saying to Alexa, and what is she saying back?



  • I'm also in trouble with alexa, if i use the routine with the command she doesn't say anything and the command doesn't execute, if i try to execute the direct command "turn on suspend" by alexa, she says "sorry it seems there are some error, to control the suspend, try to disable and activate the skill " , I use the TRIGGERcmd Smart Home skill and it worked well, in the last days the problem started, I'm from Brazil



  • @Lucas-Ribeiro, one thing you can try to troubleshoot is change your voice word, and change it back. That causes Alexa to delete and recreate the Smart Home switch device associated with that command.

    If you tell me the exact time you have the problem, I can look through the logs for clues about what went wrong.



  • @Russ I reinstalled it on my Windows and disabled and activate the skill back in and it's working. If it stop, I'll be back here to inform you, thank you.



  • @Lucas-Ribeiro thank you.



  • @Russ Alexa is working perfectly, she returns saying that the command was executed, but nothing happens ... Even if you execute the command manually by clicking on the Routine play



  • @rafaelramon, does it work if you click the Trigger button on the website?

    Also, is under View Runs, does it say, "Trigger sent from Alexa Smart Home"?



  • @Russ said in TriggerCMD skill working, but not directly:

    Trigger sent from Alexa Smart Home

    When executing the command on the website or in the GUI command, the action is executed, the problem is in the communication between Alexa and Trigger, and it happened overnight without any action by me.
    I have already changed the name of the Alexa call, I have already uninstalled the "Alexa Smart Home Trigger" and installed it again, I have reconfigured everything, but nothing solved the problem;
    When clicking on an action managed by Alexa, she returns saying that the routine was executed but nothing happens.



  • @rafaelramon, that helps.

    This is the flow:
    Alexa Routine -> Alexa TRIGGERcmd Smart Home device -> TRIGGERcmd server -> TRIGGERcmd agent -> command

    You just confirmed these parts work fine: TRIGGERcmd server -> TRIGGERcmd agent -> command

    Before we work on the Alexa Routine part, we need to make sure this part works:
    Alexa TRIGGERcmd Smart Home virtual device -> TRIGGERcmd server

    If you go to https://alexa.amazon.com, under Smart Home, Devices, do you see the device for the command you want to run?

    They look like this:
    f7843fca-269d-4e0e-9a9c-55274dd79fb3-image.png

    Even if you do see it, you should try clicking Remove All, then Discover to re-discover your commands.
    972ad99e-e03c-447a-a81a-f682bc8b050c-image.png

    One possible reason for the problem is you might have two commands with the same voice word that are conflicting. Please check that.

    One way to troubleshoot is backup your commands with a copy/paste from the Text Command Editor to another file, then delete all of your commands except the one you're trying to work on. That way you'll know it's not an issue with two commands conflicting.



  • @Russ Accessing the page, I see all the devices, exactly as they should.
    I don't have a command with the same voice, but when doing the test and deleting the routine and also in the Trigger GUI and redoing the command again.
    What happened was strange, since I didn't make any changes, it just stopped working.
    So, I think the solution is to erase everything and redo it ... Thank you.



  • @rafaelramon, one thing you could try is to delete your computer from your account then close and open the agent. It will prompt you again for your token. When you enter the token it will recreate your computer with all of your commands.

    Maybe that would fix the Alexa issue because it would recreate your Alexa devices.



  • @Russ this solved my problem, all the rules were working again. thanks for your attention and patience.



  • @rafaelramon, awesome. I still wonder what happened though.



  • This post is deleted!

Log in to reply