Group Details Private


Member List
  • RE: Issue with TriggerCMD Commands Not Updating on Website

    @fabriziotoniolo this is strange. Sorry about this trouble but I think we can figure it out.

    Can you tell me which version of the agent you have? Right now the latest is 1.0.32.

    I suggest you basically start over. To do that, rename your current .TRIGGERcmdData folder and close and open the TRIGGERcmd agent. It will re-prompt for a token then it will create a new computer. Delete your old computer record from your account after you confirm the commands are syncing.

    After that, you can restore your commands by copying your commands.json from the renamed folder.

    You'll probably want to make your new computer record your default computer too.

    posted in Windows
  • RE: Issue with TriggerCMD Commands Not Updating on Website

    @fabriziotoniolo , sorry about the trouble.

    Thank you for the screenshots. That helps. Please try these things and let me know what happens:

    • Close and re-open the TRIGGERcmd Agent, then check for the missing commands on the website.
    • Change the name of one of your commands, and see if it reflects that change on the website.

    If none of that works, you can create a new computer by deleting your computerid.cfg and token.tkn file in your C:\Users\(your user)\.TRIGGERcmdData folder, then close and open the TRIGGERcmd Agent. It will prompt for a token like when you first installed it, then it will create a new computer in your account with the same commands (stored in commands.json). Then you can delete the old computer and set your new computer as your default from your profile page.

    FYI, you don't actually have to give your computer a voice name if you only have one computer because your first computer is automatically your default computer, and your default computer doesn't need a voice name to create the Alexa devices. It doesn't hurt to give it a voice name though.

    posted in Windows
  • RE: Any idea why this batch is failing to run?

    @Strahan, that should work.

    Do you see an Alexa device called "bedtime" in the Alexa app?

    FYI, you could also remove the on and off portion of the command, and clear the "Off command" field like this because the agent will add " on" or " off" to your command depending on whether you're flipping the virtual switch on or off.

    Trigger: bedtime
    Command: c:\misc\loghealth.bat bedtime

    At first I was concerned that bedtime might be a reserved word, but I tried "bedtime" and "bed time" in the Voice field and both worked for me.


    posted in Windows
  • RE: Start computer linux

    @Anderson-Lajes, I installed the TRIGGERcmd agent on Mint Linux and it worked well for me.


    If you run it on Hyper-V, you'll want to use a Generation 2 virtual machine, and disable secure boot.

    Also, to use the Background Service you'll need nodejs installed:

    sudo apt install nodejs
    posted in Linux
  • RE: Start computer linux

    @Anderson-Lajes, I'll give it a try and get back to you soon.

    posted in Linux
  • RE: New SmartThings integration (2023)

    @Diego-Guerra, can you send me screenshots of your SmartThings values in your profile and the connector you created in your SmartThings account? I want to see that they match. Send them via the Forum chat to keep them private.

    posted in Announcements
  • RE: Hi i live in brazil

    @marciosenaf, for the TRIGGERcmd Smart Home skill to create devices, your commands need the voice field filled in, and the computer needs the voice field field in unless it's your default computer.

    I suspect your first computer was the default computer but your new one is not. If so, you could fix this by setting your new computer as your default computer in your profile.

    Click your name in the upper-right, and click Profile, then use the Default Computer pulldown to select your computer.


    posted in General Discussion
  • RE: Cannot subscribe: Stripe link down

    @ayoubshadi, what country are you from? And what payment methods do people use there? I'd like to start working on a plan B in case my Stripe appeal doesn't work out.

    posted in General Discussion
  • RE: Cannot subscribe: Stripe link down

    @ayoubshadi, thank you for reporting the problem. I'm looking into it now.

    EDIT: I found out Stripe put my account on hold because someone disputed the TRIGGERcmd subscription charge and said the charge wasn't authorized. I just replied to their email requesting information. I'll keep you posted. In the meantime I'll remove the Stripe payment link.

    posted in General Discussion
  • RE: Win11 - I put token nothing happened

    @Vportel, please re-download the installer. That was a bug I fixed. The current version works. I just re-tested it on Windows 11.

    posted in General Discussion